hubris fails to install with: Missing C libraries: ruby, ruby, ruby



I am desperately trying to install Hubris but the installation fails whenever I run "cabal install".


Link to Hurbis:
https://github.com/mwotton/Hubris/tree/master/Haskell


Link to the Cabal file:
https://github.com/mwotton/Hubris/blob/master/Haskell/hubris.cabal


The cabal command that fails is:


cabal install --extra-include-dirs=/usr/include/ruby-1.9.1/x86_64-linux --extra-include-dirs=/usr/include/ruby-1.9.1 --extra-lib-dirs=/usr/lib --user --enable-shared --with-ghc=/usr/local/bin/ghc

The error message is:


Resolving dependencies..

Related to : hubris fails to install with: Missing C libraries: ruby, ruby, ruby
Is there a location for custom Ruby libraries to be stored so Ruby can find them?
Programming Languages

I have written a module that has some generic, reusable code that I would like to be able to use in other projects. Is there a place I could put this file on computer so that Ruby can find it regardless of where I saved the file that is including it? I am using a Mac.


Completing install of ruby 1.9.3 with Ruby for for Mac OS X 10.7.5 Leopard, Xcode 4.5.2 — problems with rvm pkg install openssl
Programming Languages

First, many thanks in advance for any help. I'm a complete novice with programming and I'm trying to get started with this Ruby on Rails tutorial (http://ruby.railstutorial.org/ruby-on-rails-tutorial-book?version=3.2)


I have been trying figure this out for about 7 hours now and since I don't have any hair left to pull out I'm turning to these hallowed pages. I have searched for solutions here again and again.


System: Mac OS X 10.7.5 Leopard, Xcode 4.5.2


I installed homebrew and have updated it multiple times
I used homebrew to install rvm and have updated it multiple times
I installed git


The sta

Failing to install ruby gem “yajl-ruby”
Programming Languages

I am trying to install the ruby gem "yajl ruby". I'm running Mac OS 10.7.4 and Ruby 1.8.7 (2011-12-28 patchlevel 357) [universal-darwin11.0]. When I run:


sudo gem install yajl-ruby

I get the following output:


Building native extensions. This could take a while...
ERROR: Error installing yajl-ruby:
ERROR: Failed to build gem native extension.
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb
creating Makefile
make
gcc -I. - I/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/universal-darwin11.0
How can I programatically call the ruby debugger from within a ruby program in Ruby 1.9?
Programming Languages

I am writing a web based debugger for Ruby, but in order to do this I need to be able to call the Ruby debugger from within a Ruby program on the server side. Has this ever been done? Is this even possible?


The end product being built will allow Ruby code to be edited, executed and stepped through using just a web browser. The ruby code that is to be debugged will be "eval"ed on the server side.


I have since been pointed in the right direction by one of the stackoverflow users who has suggested using popen or expect. I have tried both of these now but have encountered the following problems:


popen: When waiting for the console yo

Ruby: Generate/modify Ruby source files from within Ruby
Programming Languages

What is the most reliable way to generate and/or parse and modify a Ruby source file from within ruby?


That is, I want to e.g. create a new ruby source file or change a few lines of code in a class in a source file to e.g. add or remove methods or calls or whatever.


Is there a library for this perhaps?


ruby & rvm - how to install a “p” version of ruby
Programming Languages

How can I use rvm to install a specific version of Ruby, e.g. 1.9.3p327 instead of the current 1.9.3p194 that I have.


All the references and document are about the major version, e.g. rvm install 1.9.3 but don't mention the 'p' minor version numbers.


I tried


$ rvm install 1.9.3p327
Unknown ruby interpreter version: '1.9.3p327'.
Could not detect ruby version/name for installation, please be more specific.
$ ruby -v
ruby 1.9.3p194 (2012-04-20 revision 35410) [i686-linux]
$ rvm install '1.9.3p327'
Unknown ruby interpreter version: '1.9.3p327'.
Could
After ruby upgrade, upon new deployment Bundler fails with Ruby version mismatch error
Programming Languages

I have installed ruby on Ubuntu 14.04 server on digital ocean using brightbox's ppa. Typical sinatra/unicorn in ruby 2.1.2 using the following setup:

$ ruby -v
ruby 2.1.2p95 (2014-05-08 revision 45877) [x86_64-linux-gnu]

here is my gemfile:

source 'https://rubygems.org'

ruby "2.1.2"

gem 'sinatra'

now, I upgraded ruby to ruby 2.1.4 using following command:

$ apt-get update && apt-get upgrade

and, then I locally updated my gemfile with :

source 'https://rubygems.org'

ruby "2.1.4"

gem 'sinatra'

But now, I can no longer deploy:

-----> Creating a temporary build path
-----> Fetching new git commits
-----> Using git branch 'mysql-store'
       Cloning into '.'...
       done.
-----> Using this git commit

       XXXX XXXX (3dbdq19):
       > Upgrade to ruby 2.1.4

-----> Installing gem dependencies using Bundler
       Your Ruby version is 2.1.4, but your Gemfile specified 2.1.2
 !     ERROR: Deploy failed.
-----> Cleaning up build
       Unlinking current
       OK

 !     Command failed.
       Failed with status 19

OS: Ubuntu 14.04 LTS Host: Digital Ocean Bundler 1.7.6 Sinatra

Any idea what the problem could be? And how can I solve this?



HD Wallpapers
3D
3D Abstract
City
Celebrities
Indian Celebrities
Cars
Travel
Girls
Animals Birds
Movies
Sports
Black White
Nature
Planes
Anime
Food Drink
Dreamy Fantasy
Architecture
Games
Space
Holidays
Flowers
Love
Artistic
Baby
Beach
Bikes Motorcycles
Macro
Computers
Vector
Funny
Army
Textures
Brands
Misc
Music
Other
Privacy Policy - Copyrights Notice - Feedback - Report Violation - RSS 2017 © bighow.org All Rights Reserved .