Rails console won't load, “Could not find gem 'rails (= 3.0.0.beta3) ruby”


Davidpaul007
HOME ยป Programming Languages

I typed in Rails console to begin working and received the error below:


MacBook-Pro:blog agreiner$ rails console
/Users/agreiner/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.3/lib/bundler/resolver.rb:287:in `resolve': Could not find gem 'rails (= 3.0.0.beta3) ruby' in the gems available on this machine. (Bundler::GemNotFound)
from /Users/agreiner/.rvm/gems/ruby-1.9.3-p194/gems/bundler 1.1.3/lib/bundler/resolver.rb:161:in `start'
from /Users/agreiner/.rvm/gems/ruby-1.9.3-p194/gems/bundler 1.1.3/lib/bundler/resolver.rb:128:in `block in resolve'
from /Users/agreiner/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.3/lib/bundler/resolver.rb:127:in `catch

Related to : Rails console won't load, “Could not find gem 'rails (= 3.0.0.beta3) ruby”
Rails console won't load, “Could not find gem 'rails (= 3.0.0.beta3) ruby”
by Davidpaul007 in Programming Languages

I typed in Rails console to begin working and received the error below:


MacBook-Pro:blog agreiner$ rails console
/Users/agreiner/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.3/lib/bundler/resolver.rb:287:in `resolve': Could not find gem 'rails (= 3.0.0.beta3) ruby' in the gems a
script/console won't work; reports “Missing the Rails gem. Please `gem install -v= rails`…” even though rails shows as installe
by l1feh4ck3r in Programming Languages

I'm trying to learn RoR, and running script/console fails, returning:


Loading development environment (Rails 2.3.5)
Missing the Rails gem. Please gem install -v= rails, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have


Routes.rb - from Rails 2.x to Rails 3.x “How to Create a Blog from Scratch Using Ruby on Rails” tutorial
by redha in Programming Languages

I'am working on "How to Create a Blog from Scratch Using Ruby on Rails" from http://sixrevisions.com. The tutorial was created for Rails 2.x. I try to get It working on Rails 3.x. . When I run server I and run localhost:3000 get some serious routing error:


Called from: C:/Ruby
when i run “rails s” i get “dependencies.rb:240:in `require': no such file load — gettext/rails (LoadError)”
by S Hall in Programming Languages

I cant run "rails s" eny more and I cant understand why.
I work on windows.
When i try to run "rails s" i get this error:


$ rails s
=> Booting WEBrick
=> Rails 3.1.1 application starting in development on http://0.0.0.0:3000
=> Call with -d to deta
I thought Ruby on Rails “script/console” can let me do “render :text => 'hello' ” but it says render is not defined
by boobytrapped in Programming Languages

I thought Ruby on Rails "script/console" can let me do "render :text => 'hello' " but it says render is not defined?


Does the hoster has to support “Ruby on Rails” or “just Ruby” to run Rails?
by Ed. in Programming Languages

Does the hoster have to support "Ruby on Rails" or "just Ruby" to run Rails?


I know mainly PHP and ask myself if "Ruby on Rails" behaves to Ruby ... like "Zend Framework" to PHP: just a bunch of PHP files I can copy in my project folder and my hoster only needs to support PHP.


TAGS: Does hoster support ldquo Ruby Rails
What is the “Rails Way” to create the related row at the time the other row is created in Ruby on Rails
by chardin in Programming Languages

I have two tables: Lessons and Pages


lessons "has_many" pages
pages "belongs_to" lessons

When a new lesson is created I want the first page to be created at the same time.
The first page will have:


the lesson_id column equal to the newly created lessons id
TAGS: What ldquo Rails rdquo create related
Ruby on rails - “cannot load Java class com.ibm.db2.jcc.DB2Driver”
by Israel in Programming Languages

I am using:


Ubuntu 12.04 LTC
JRuby 1.7.2
Rails 3.2.12
DB2 C express 10.1

My database.yml file looks like this:


development:
adapter: jdbc
driver: com.ibm.db2.jcc.DB2Driver
url: localhost:50001/devdb
host: localhost

How can I make my Ruby on Rails 2.3.4 application “Rails 3-ready”
by AJ. in Programming Languages

I'm developing an application with Ruby on Rails that I want to maintain for at least a few years, so I'm concerned about the next version coming up soon.


Going from Rails 1 to Rails 2 was such a big pain that I didn't bother and froze my gems and let the application die, alone, in th


Ruby/Rails - delayed_job Rails.env is “development” when I'm in production
by boobytrapped in Programming Languages

I'm running Ruby 1.9.2/Rails 3.0.9.


I am using the collective idea fork of delayed_job


I am starting delayed_job like so:
RAILS_ENV=production script/delayed_job start


It pulls jobs from my production database.


However, when proces


Privacy Policy - Copyrights Notice - Feedback - Report Violation - RSS 2014 © bighow.org All Rights Reserved .