Rails gem error while trying to upgrade rails project to rails 3



While trying to upgrade rails project from rails 2.3.5 to rails 3.0.3 i get following error:-


/opt/ruby-enterprise-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems.rb:230:in
activate': can't activate rails (=
2.3.5, runtime) for [], already activated rails-3.0.3 for []
(Gem::LoadError) from
/opt/ruby-enterprise-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:35:in
require' from
./script/../config/boot.rb:54:in
load_initializer' from
./script/../config/boot.rb:38:in
run'
from ./script/../config/boot.rb:11:in
boot!' from


Related to : Rails gem error while trying to upgrade rails project to rails 3
Mac Rails install— error: Error installing rails: invalid gem format for /Users/…/cache/railties-3.2.3.gem
Programming Languages

Using the Ruby on Rails tutorial for OSX here: http://ruby.railstutorial.org/book/ruby-on-rails-tutorial


It states to install the rails via "$ gem install rails -v 3.2.3", and when I do that I get the error


Error installing rails:
invalid gem format for /Users//.rvm/gems/ruby-1.9.3-p194@rails3tutorial2ndEd/cache/railties-3.2.3.gem



Rails - Cant get http_accept_language gem to work in my rails project
Programming Languages

I'm internationalizing my app and I've installed the http_accept_language gem on my system I've placed config.gem 'http_accept_language' into my environment.rb file but every time I try to run this code in my controller


request.user_preferred_languages


it complains of no method error.


There are no other instructions on the readme on github... am I missing something?


EDIT - Problem solved.


after a good nights sleep I came back and realised I hadnt restarted the server. I hate it when that happens.


Rails gem error while trying to upgrade rails project to rails 3
Programming Languages

While trying to upgrade rails project from rails 2.3.5 to rails 3.0.3 i get following error:-


/opt/ruby-enterprise-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems.rb:230:in
activate': can't activate rails (=
2.3.5, runtime) for [], already activated rails-3.0.3 for []
(Gem::LoadError) from
/opt/ruby-enterprise-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:35:in
require' from
./script/../config/boot.rb:54:in
load_initializer' from
./script/../config/boot.rb:38:in
run'
from ./script/../config/boot.rb:11:in
boot!' from

How do I setup a rails project to use an edge source tree (not an installed gem) version of rails
Programming Languages

I would like the rails 3.0 source tree in my project so I can use patches, etc. I don' want to freeze rails. I would like to be able to pull updates from the main repo too. How do I accomplish this?


In particular the getting started guide, has me confused with


As the root user:
# gem install bundler
# bundle install

If I install the bundled gems to my system then I'm not really running with the vendor/rails source tree. Do rails developers really edit-test-edit-test and then install gems to their system before trying out patches on an actual app?


--- Update ---


$
script/console won't work; reports “Missing the Rails gem. Please `gem install -v= rails`…” even though rails shows as installe
Programming Languages

I'm trying to learn RoR, and running script/console fails, returning:


Loading development environment (Rails 2.3.5)
Missing the Rails gem. Please gem install -v= rails, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.


Both gem list and sudo gem list show rails (2.3.5) as installed. Additionally, script/server works fine. I found some sources that suggested the problem might be with rack (1.1.0), so I reverted back to 1.0.1, but it didn't help.


I'd love any s

why am I getting 'could not find gem rails locally…' when trying to upgrade InstantRails2.0 to rails 2.3?
Programming Languages

The full error message is "could not find rails gem locally or in a repository". I've read the Rails Wiki about upgrading rails and it doesn't have any info on this error. I'm running on WinXp. The Rails Wiki said I needed to first do update_rubygems, and it appears I was able to do that successfully. My ruby version is 1.8.6. I googled this particular error and got a few hits about making sure the gem sources included gems.rubyonrails.org, which mine does.


Any suggestions? What other environment info do I need to provide?


Is there a way to download and install the latest version of rails if I continue to have issues?



Privacy Policy - Copyrights Notice - Feedback - Report Violation - RSS 2017 © bighow.org All Rights Reserved .