Lenovo Yoga 900 - Touchscreen & Touchpad not working


HOME ยป Ubuntu
Hi, I am new to Ubuntu (and Linux pretty much) I bought a Lenovo
Yoga 900 for a new laptop, but when I saw how ugly everything looked
on Windows 10, I decided I should just move to Ubuntu. Right now, I am
using Ubuntu Gnome 15.10. What is working is the Wireless
Connectivity, Webcam, Keyboard, USB Ports, though the only things that
are not working is the touchscreen and touchpad! I looked at some
forums, but they were to complicated to understand. If anyone can find
an answer, please try to be as simple as possible. Thanks.
On Ubuntu Netbook Remix 9.04, I could slide two fingers together to
scroll and "pinch" to zoom. This no longer works on 9.10. A
two-finger tap now is a right-click, and the three-finger tap is the
middle click; this was the reverse before. (This one might be a
purposeful change, perhaps?) I have updated everything and restarted
twice. If you know of a solution, please let me know.
Ubuntu
Hey Ubuntu-friends,
I have a Lenovo Ideacentre A720 and using
ubuntu 12.04 after a lot of hard work with installing everything by
hand (graphic, sound, wlan, sd-card)
Sadly there is almost no
experience about ubuntu on this device in the web
I'd like to
use the Multitouchscreen, just Monotouch would be als ok.
It's a
27" CoolTouch(TM) from the Advanced Silicon S.A. Company
http://www.advancedsilicon.com/web/p...cooltouch.html />xserver-xorg-input-evdev is installed
some more infos

class="bbcode_description">Code:
Ubuntu
Hi,
I have seen some posts about this particular laptop, but I
can't seem to get around the issue.
My touchscreen worked fine on
windows - it doesn't work at all with ubuntu 13.1. Does anyone have
any advice on how to fix the problem - I am not that familiar with the
platform, so if there are any steps I need to take, can you please
explain them like I am a 5 year old child (not the coder savant 5 year
old).
Thanks!
Ubuntu

i just installed Ubuntu 14.04 on my brand new Lenovo Pro Yoga
3.



But my touchpad isn't working. When I run /proc/bus/input/device on
my machine, I don't see a touchpad part of it at all. How do I get
Ubuntu to detect it?

Ubuntu
Good evening all,



I have been trying to get the wireless working on my Lenovo Yoga 3
Pro. As soon as I got the laptop I stripped the factory operating
system off of it and installed Ubuntu 14.04 LTS and the wireless
controller worked after a installing the bcmwl-kernel-source and
blacklisting ideapad_laptop. The problem was that the touchpad and the
touchscreen didn't work. I submitted a bug report to see if I could
get the touchpad working. The guys at the bug reporting center had me
upgrade the kernel to the mainline kernel. After updating the kernel
my touchpad and touchscreen now work, but the Wireless Controller is
not working. I have been searching and troubleshooting for quite a
while now. I have tried a lot of things, with not much luck.



I have tried the workaround here

HTML Code:


class="bbcode_code">http://ubuntuforums.org/showthread.php?t=2214110 />
with no luck, and the solution that got the wifi working in
14.04 didn't work in 14.10.



Here is the wireless info from the script found on the sticky here:

HTML Code:


class="bbcode_code">http://ubuntuforums.org/showthread.php?t=370108 />

Code:


########## wireless info START
##########



Report from: 13 Jan 2015 21:33 CST -0600



Booted last: 13 Jan 2015 21:24 CST -0600



Script from: 20 Sep 2014 23:04 UTC +0000



##### release ###########################



Distributor ID:        Ubuntu

Description:        Ubuntu 14.10

Release:        14.10

Codename:        utopic



##### kernel ############################



Linux 3.19.0-031900rc4-generic #201501112135 SMP Sun Jan 11 21:36:48
UTC 2015 x86_64 x86_64 x86_64 GNU/Linux



Parameters: ro, quiet, splash, vt.handoff=7



##### desktop ###########################



Ubuntu



##### lspci #############################



01:00.0 Network controller [0280]: Broadcom Corporation BCM4352
802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)

        Subsystem: Lenovo Device [17aa:0623]



##### lsusb #############################



Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 001 Device 004: ID 048d:8386 Integrated Technology Express, Inc.


Bus 001 Device 003: ID 5986:0535 Acer, Inc

Bus 001 Device 002: ID 0489:e07a Foxconn / Hon Hai

Bus 001 Device 006: ID 18d1:4ee3 Google Inc. Nexus 4 (tether)

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub



##### PCMCIA card info ##################



##### rfkill ############################



0: hci0: Bluetooth

        Soft blocked: no

        Hard blocked: no



##### lsmod #############################



wmi                 
  19379  0



##### interfaces ########################



auto lo

iface lo inet loopback



##### ifconfig ##########################



usb0      Link encap:Ethernet  HWaddr <MAC
'usb0' [IF]> 

          inet addr:192.168.42.133 
Bcast:192.168.42.255  Mask:255.255.255.0

          inet6 addr:
fe80::6097:1fff:fe3a:1fba/64 Scope:Link

          UP BROADCAST RUNNING
MULTICAST  MTU:1500  Metric:1

          RX packets:2270 errors:0 dropped:0
overruns:0 frame:0

          TX packets:2329 errors:0 dropped:0
overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:1067465 (1.0 MB)  TX
bytes:608577 (608.5 KB)



##### iwconfig ##########################



usb0      no wireless extensions.



lo        no wireless extensions.



##### route #############################



Kernel IP routing table

Destination    Gateway       
Genmask        Flags Metric Ref    Use
Iface

0.0.0.0        192.168.42.129  0.0.0.0 
      UG    0      0 
      0 usb0

192.168.42.0    0.0.0.0       
255.255.255.0  U    1      0 
      0 usb0



##### resolv.conf #######################



nameserver 127.0.1.1



##### nm-tool ###########################



NetworkManager Tool



State: connected (global)



- Device: usb0  [Wired connection 1]
-------------------------------------------

  Type:              Wired />
  Driver:            rndis_host />
  State:            connected />
  Default:          yes

  HW Address:        <MAC 'usb0'
[IF]>



  Capabilities:

    Carrier Detect:  yes



  Wired Properties

    Carrier:        on



  IPv4 Settings:

    Address:        192.168.42.133 />
    Prefix:          24
(255.255.255.0)

    Gateway:        192.168.42.129 />


    DNS:           
192.168.42.129



##### NetworkManager.state ##############



[main]

NetworkingEnabled=true

WirelessEnabled=true

WWANEnabled=true

WimaxEnabled=true



##### NetworkManager.conf ###############



[main]

plugins=ifupdown,keyfile,ofono

dns=dnsmasq



[ifupdown]

managed=false



##### NetworkManager profiles ###########



[[/etc/NetworkManager/system-connections/UCO_SECURE]] (600 root)

[ipv6] method=auto

[connection] id=UCO_SECURE | type=802-11-wireless

[802-11-wireless] ssid=UCO_SECURE | mac-address=<MAC address> />
[ipv4] method=auto



[[/etc/NetworkManager/system-connections/FilthyNet]] (600 root)

[connection] id=FilthyNet | type=802-11-wireless

[802-11-wireless] ssid=FilthyNet | mac-address=<MAC address> />
[ipv4] method=auto

[ipv6] method=auto



##### iw reg get ########################



Region: America/Chicago (based on set time zone)



country 00: DFS-UNSET

        (2402 - 2472 @ 40), (6, 20)

        (2457 - 2482 @ 40), (6, 20),
PASSIVE-SCAN

        (2474 - 2494 @ 20), (6, 20), NO-OFDM,
PASSIVE-SCAN

        (5170 - 5250 @ 160), (6, 20),
PASSIVE-SCAN

        (5250 - 5330 @ 160), (6, 20), DFS,
PASSIVE-SCAN

        (5490 - 5730 @ 160), (6, 20), DFS,
PASSIVE-SCAN



##### iwlist channels ###################



usb0      no frequency information.



lo        no frequency information.



##### iwlist scan #######################



usb0      Interface doesn't support scanning.



lo        Interface doesn't support scanning. />


##### module infos ######################



##### module parameters #################



##### /etc/modules ######################



lp



##### modprobe options ##################



[/etc/modprobe.d/blacklist-ath_pci.conf]

blacklist ath_pci



[/etc/modprobe.d/blacklist-bcm43.conf]

blacklist b43

blacklist b43legacy

blacklist ssb

blacklist bcm43xx

blacklist brcm80211

blacklist brcmfmac

blacklist brcmsmac

blacklist bcma



[/etc/modprobe.d/blacklist.conf]

blacklist evbug

blacklist usbmouse

blacklist usbkbd

blacklist eepro100

blacklist de4x5

blacklist eth1394

blacklist snd_intel8x0m

blacklist snd_aw2

blacklist i2c_i801

blacklist prism54

blacklist bcm43xx

blacklist garmin_gps

blacklist asus_acpi

blacklist snd_pcsp

blacklist pcspkr

blacklist amd76x_edac

blacklist ideapad_laptop



[/etc/modprobe.d/blacklist-rare-network.conf]

alias net-pf-3 off

alias net-pf-6 off

alias net-pf-9 off

alias net-pf-11 off

alias net-pf-12 off

alias net-pf-19 off

alias net-pf-21 off

alias net-pf-36 off



[/etc/modprobe.d/iwlwifi.conf]

remove iwlwifi

(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs
/sbin/rmmod)

&& /sbin/modprobe -r mac80211



[/etc/modprobe.d/mlx4.conf]

softdep mlx4_core post: mlx4_en



[/etc/modprobe.d/modesetting.conf]

options cirrus modeset=1

options mgag200 modeset=1



##### rc.local ##########################



exit 0



##### pm-utils ##########################



##### udev rules ########################



[/etc/udev/rules.d/70-persistent-net.rules]

# PCI device 0x14e4:0x43b1 (wl)

SUBSYSTEM=="net", ACTION=="add",
DRIVERS=="?*", ATTR{address}=="<MAC
address>", ATTR{dev_id}=="0x0",
ATTR{type}=="1", KERNEL=="wlan*",
NAME="wlan0"



##### dmesg #############################



[    3.954757] bluetooth hci0: Direct firmware load for
brcm/BCM20702A0-0489-e07a.hcd failed with error -2

[    3.954759] Bluetooth: hci0: BCM: patch
brcm/BCM20702A0-0489-e07a.hcd not found



########## wireless info END ############


Any help that anyone could offer would be fantastic.
Ubuntu
Hi, I am new to Ubuntu (and Linux pretty much) I bought a Lenovo
Yoga 900 for a new laptop, but when I saw how ugly everything looked
on Windows 10, I decided I should just move to Ubuntu. Right now, I am
using Ubuntu Gnome 15.10. What is working is the Wireless
Connectivity, Webcam, Keyboard, USB Ports, though the only things that
are not working is the touchscreen and touchpad! I looked at some
forums, but they were to complicated to understand. If anyone can find
an answer, please try to be as simple as possible. Thanks.
Ubuntu

- Technology - Languages
+ Webmasters
+ Development
+ Development Tools
+ Internet
+ Mobile Programming
+ Linux
+ Unix
+ Apple
+ Ubuntu
+ Mobile & Tablets
+ Databases
+ Android
+ Network & Servers
+ Operating Systems
+ Coding
+ Design Software
+ Web Development
+ Game Development
+ Access
+ Excel
+ Web Design
+ Web Hosting
+ Web Site Reviews
+ Domain Name
+ Information Security
+ Software
+ Computers
+ Electronics
+ Hardware
+ Windows
+ PHP
+ ASP/ASP.Net
+ C/C++/C#
+ VB/VB.Net
+ JAVA
+ Javascript
+ Programming
Privacy Policy - Copyrights Notice - Feedback - Report Violation 2018 © BigHow