Error installing ruby-debug/ruby-debug-base with Ruby Enterprise v1.8.7



I got problems when trying to install gem ruby-debug-ide. Then, I try to install gem ruby-debug-base first. However, I got an error:


Error installing ruby-debug-base:
rb-threadframe requires Ruby version ~> 1.9.2frame.

The same error occured when installing ruby-debug.


I'm using Ubuntu v10.4, Ruby Enterprise v1.8.7, Rubygems v1.8.15.


Thanks for your help!


Related to : Error installing ruby-debug/ruby-debug-base with Ruby Enterprise v1.8.7
How to debug Ruby base methods in Netbeans?
Operating Systems

I am able to debug my ruby program. At times, I would want to go inside the library methods and see what is happening. How to achieve it in Ruby.


For example,


[ 3, 1, 7, 0 ].sort

i would want to go inside the sort method and see how that works lively. In Java+Eclipse this is possible, all I have to do is to attach the source of Foundation classes in Eclipse. Is it possible in Ruby with Netbeans as IDE?


Thanks


How to get rid of this error when trying to run ruby-debug on a ruby script
Operating Systems

I followed the instructions from here but still have trouble figuring out the problem. Would be great to hear some suggestions. Thanks in advance!


stanley@ubuntu:~/Github/webdev_class/ruby$ gem install ruby-debug19
Fetching: archive-tar-minitar-0.5.2.gem (100%)
Fetching: ruby_core_source-0.1.5.gem (100%)
Fetching: linecache19-0.5.12.gem (100%)
Building native extensions. This could take a while...
Fetching: ruby-debug-base19-0.11.25.gem (100%)
Building native extensions. This could take a while...
Fetching: ruby-debug19-0.11.6.gem (100%)
Successfully installed archive-tar-minitar-0.5.2
Successfully installed ru
Error installing ruby-debug/ruby-debug-base with Ruby Enterprise v1.8.7
Operating Systems

I got problems when trying to install gem ruby-debug-ide. Then, I try to install gem ruby-debug-base first. However, I got an error:


Error installing ruby-debug-base:
rb-threadframe requires Ruby version ~> 1.9.2frame.

The same error occured when installing ruby-debug.


I'm using Ubuntu v10.4, Ruby Enterprise v1.8.7, Rubygems v1.8.15.


Thanks for your help!


Ruby Debug IDE error : ruby-debug-ide-0.4.9/lib/ruby-debug-ide.rb:109:in `debug_load'
Operating Systems

I hope someone can assist me. I have RubyMine 2.0.2 installed on Windows 7 32 bit computer. Since a week ago (I presume it must have been after I have update some gems) I cant seem to debug form the IDE. I am trying to debug a rake task which I could before. Running the rake task normally works perfect, just debug doesnt. Its not just limited to the rake, I cant debug any ruby files. I've tried installing older versions of debug-ide and debug-base but to no success. I've tried it with ruby 1.8.7 and 1.8.6 on different computers but nothing. Trying to search the web gave some information, which I've tried, but also no success. Im desperate to get this working. Below are the full error and

Ruby - ruby-debug terminating without error on 'if __FILE__ == $0'
Operating Systems

I'm trying to use ruby-debug to debug this script I've written and it keeps terminating on the line, if __FILE__ == $0. I step through each line before it, and then when it gets to that line it just quits. No errors or anything, it just quits. How do I fix this?


RVM + Ruby 1.9.1 + ruby-debug = error?
Operating Systems

I am trying to get a decent navigation between my methods in TextMate. I would love to have a list of them in a drawer, but I guess there is no such solution yet, right? Therefore I am trying to set up RubyAMP to work with Ruby 1.9.1-p378 installed via RVM, but have some troubles. RubyAMP needs ruby-debug, and here is what I get if I try to install the gem


$ rvm gem install ruby-debug
info: ruby-1.9.1-p378: ruby 1.9.1p378 (2010-01-10 revision 26273) [x86_64-darwin10]
Building native extensions. This could take a while...
ERROR: Error installing ruby-debug:
ERROR: Failed to buil

Privacy Policy - Copyrights Notice - Feedback - Report Violation - RSS 2017 © bighow.org All Rights Reserved .