script/console won't work; reports “Missing the Rails gem. Please `gem install -v= rails`…” even though rails shows as installe


l1feh4ck3r
HOME ยป Programming Languages

I'm trying to learn RoR, and running script/console fails, returning:


Loading development environment (Rails 2.3.5)
Missing the Rails gem. Please gem install -v= rails, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.


Both gem list and sudo gem list show rails (2.3.5) as installed. Additionally, script/server works fine. I found some sources that suggested the problem might be with rack (1.1.0), so I reverted back to 1.0.1, but it didn't help.


I'd love any s


Related to : script/console won't work; reports “Missing the Rails gem. Please `gem install -v= rails`…” even though rails shows as installe
script/console won't work; reports “Missing the Rails gem. Please `gem install -v= rails`…” even though rails shows as installe
by l1feh4ck3r in Programming Languages

I'm trying to learn RoR, and running script/console fails, returning:


Loading development environment (Rails 2.3.5)
Missing the Rails gem. Please gem install -v= rails, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have


Rails “script/plugin” install http://github.com…git hangs on 'git pull'
by CraKaJaX in Programming Languages

Whenever I run the rails script/plugin install to install a plugin using git, from github it "hangs".


$ script/plugin -v install http://github.com/ryanstout/blog_kit.git

It "hangs". the -v gives me the following output:


Plugins will be installed
Rails console won't load, “Could not find gem 'rails (= 3.0.0.beta3) ruby”
by Davidpaul007 in Programming Languages

I typed in Rails console to begin working and received the error below:


MacBook-Pro:blog agreiner$ rails console
/Users/agreiner/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.3/lib/bundler/resolver.rb:287:in `resolve': Could not find gem 'rails (= 3.0.0.beta3) ruby' in the gems a
Rails + Passenger + Apache Production Deployment: “Missing Rails 2.3.5 gem” but it's installed
by snapshooter in Programming Languages

I've looked all over the web for about a week now and not found a solution to my problem. I have a Ruby on Rails application I'm trying to deploy to a production Ubuntu 10.04 server edition box. I've got Apache2.2 and Passenger3.0.0 installed with Ruby 1.8.7, Rails 2.3.5 and RubyGems 1.3.7. My ra


Routes.rb - from Rails 2.x to Rails 3.x “How to Create a Blog from Scratch Using Ruby on Rails” tutorial
by redha in Programming Languages

I'am working on "How to Create a Blog from Scratch Using Ruby on Rails" from http://sixrevisions.com. The tutorial was created for Rails 2.x. I try to get It working on Rails 3.x. . When I run server I and run localhost:3000 get some serious routing error:


Called from: C:/Ruby
Rails: How can I define one-to-many relationships using the rails “generate” script?
by reflexiv in Programming Languages

I'd like to run the rails "generate" script and create a model that belongs two other models. Is there a way that I can do this?


Rails 3's “bundle install” is super fast (takes 1 second), but no Rails is there afterwards? (using rvm)
by Jaleel in Programming Languages

I am using rvm, doing the following:


rvm install ree <--- (Ruby Enterprise Edition), or this can be 1.8.7 or 1.9.2
rvm ree
rvm gemset create 'proj'
cd path/to/proj
bundle install

so Gemfile in that project says:


gem 'rai
Fresh Rails install on Mac OS X gives me “Rails requires RubyGems >= 1.3.2”
by Sankarsan Bose in Programming Languages

I just set up a fresh Mac OS X 10.5 environment for Rails. I installed Ruby 1.8.7, renamed the packaged version of Ruby in /usr/bin, and updated the packaged version of RubyGems from 1.0.1 to 1.3.4. Here's the flow:


$ rails -v
Rails 2.3.4
$ gem -v
1.3.4
$ which gem<
Heroku Rails 3 Rails.cache.class reports ActiveSupport::Cache::FileStore after I call Rails.application.config.cache_store = :redis_store, “#{ur
by krismolendyke in Programming Languages

Where url=redis://redistogo:XXXYYYZZZ@cod.redistogo.com:9362/


This is called in my initializer code.


Here is the other pertinent config options:


1) in production.rb


config.action_controller.perform_caching = true in my production.rb
Using the “pg” gem with Rails 3 … why am I getting this error in Netbeans when I do a “bundle install”?
by Robby in Programming Languages

At my wits end with this!


My current set up is:
- Ruby 1.9.2
- Rails 3.0.1
- pg (0.9.0)


My $PATH right now looks like this:


/Users/fjones/.rvm/gems/ruby-1.9.2-p0/bin:/Users/fjones/.rvm/gems/ruby-1.9.2-p0@global/bin:/Users/fjones/.rvm/rubies/ru




HD Wallpapers
3D
3D Abstract
City
Celebrities
Indian Celebrities
Cars
Travel
Girls
Animals Birds
Movies
Sports
Black White
Nature
Planes
Anime
Food Drink
Dreamy Fantasy
Architecture
Games
Space
Holidays
Flowers
Love
Artistic
Baby
Beach
Bikes Motorcycles
Macro
Computers
Vector
Funny
Army
Textures
Brands
Misc
Music
Other
Privacy Policy - Copyrights Notice - Feedback - Report Violation - RSS 2017 © bighow.org All Rights Reserved .