script/console won't work; reports “Missing the Rails gem. Please `gem install -v= rails`…” even though rails shows as installe



I'm trying to learn RoR, and running script/console fails, returning:


Loading development environment (Rails 2.3.5)
Missing the Rails gem. Please gem install -v= rails, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.


Both gem list and sudo gem list show rails (2.3.5) as installed. Additionally, script/server works fine. I found some sources that suggested the problem might be with rack (1.1.0), so I reverted back to 1.0.1, but it didn't help.


I'd love any s


Related to : script/console won't work; reports “Missing the Rails gem. Please `gem install -v= rails`…” even though rails shows as installe
Mac Rails install— error: Error installing rails: invalid gem format for /Users/…/cache/railties-3.2.3.gem
Programming Languages

Using the Ruby on Rails tutorial for OSX here: http://ruby.railstutorial.org/book/ruby-on-rails-tutorial


It states to install the rails via "$ gem install rails -v 3.2.3", and when I do that I get the error


Error installing rails:
invalid gem format for /Users//.rvm/gems/ruby-1.9.3-p194@rails3tutorial2ndEd/cache/railties-3.2.3.gem



Rails console won't load, “Could not find gem 'rails (= 3.0.0.beta3) ruby”
Programming Languages

I typed in Rails console to begin working and received the error below:


MacBook-Pro:blog agreiner$ rails console
/Users/agreiner/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.3/lib/bundler/resolver.rb:287:in `resolve': Could not find gem 'rails (= 3.0.0.beta3) ruby' in the gems available on this machine. (Bundler::GemNotFound)
from /Users/agreiner/.rvm/gems/ruby-1.9.3-p194/gems/bundler 1.1.3/lib/bundler/resolver.rb:161:in `start'
from /Users/agreiner/.rvm/gems/ruby-1.9.3-p194/gems/bundler 1.1.3/lib/bundler/resolver.rb:128:in `block in resolve'
from /Users/agreiner/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.3/lib/bundler/resolver.rb:127:in `catch
Rails + Passenger + Apache Production Deployment: “Missing Rails 2.3.5 gem” but it's installed
Programming Languages

I've looked all over the web for about a week now and not found a solution to my problem. I have a Ruby on Rails application I'm trying to deploy to a production Ubuntu 10.04 server edition box. I've got Apache2.2 and Passenger3.0.0 installed with Ruby 1.8.7, Rails 2.3.5 and RubyGems 1.3.7. My rails application is in /var/rails_app_name/ and rubygems/ruby is installed at /var/lib/gems/1.8


I have a test server with ubuntu 10.04 (gui edition) running the same setup and configuration which works like a charm. The only difference is my rails application root is in the user local folder e.g. /home/username/rails_app_name/


Receive: “ERROR: Failed to build gem native extension” when trying to install rails gem on ruby 1.9.2 using pik
Programming Languages

I was trying to push my local database to Heroku and received this error:


...Taps Server Error: PGError: ERROR: time zone displacement out of range:...


Some googling later I discovered that this error doesn't occur with ruby 1.9.2 and that (because being on windows) I'd have to install pik to run 1.9.2 alongside 1.9.3. So I installed pik and ruby 1.9.2.


However, when I try to install rails on 1.9.2 I get this error:


...ERROR: Failed to build gem native extension...


After plenty of googling I've ran into the follo

script/console won't work; reports “Missing the Rails gem. Please `gem install -v= rails`…” even though rails shows as installe
Programming Languages

I'm trying to learn RoR, and running script/console fails, returning:


Loading development environment (Rails 2.3.5)
Missing the Rails gem. Please gem install -v= rails, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.


Both gem list and sudo gem list show rails (2.3.5) as installed. Additionally, script/server works fine. I found some sources that suggested the problem might be with rack (1.1.0), so I reverted back to 1.0.1, but it didn't help.


I'd love any s

Using the “pg” gem with Rails 3 … why am I getting this error in Netbeans when I do a “bundle install”?
Programming Languages

At my wits end with this!


My current set up is:
- Ruby 1.9.2
- Rails 3.0.1
- pg (0.9.0)


My $PATH right now looks like this:


/Users/fjones/.rvm/gems/ruby-1.9.2-p0/bin:/Users/fjones/.rvm/gems/ruby-1.9.2-p0@global/bin:/Users/fjones/.rvm/rubies/ruby-1.9.2-p0/bin:/Users/fjones/.rvm/bin:ARCHFLAGS=-arch
x86_64:/opt/local/bin:/opt/local/sbin:/opt/local/lib/postgresql84/bin:/Library/Glassfish/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin


Anytime I attempt to do a "bundle install" from Netbeans 6.9.1 I get the following exception.


In


Privacy Policy - Copyrights Notice - Feedback - Report Violation - RSS 2017 © bighow.org All Rights Reserved .