» Home » Rails » Page 1
Routes.rb - from Rails 2.x to Rails 3.x “How to Create a Blog from Scratch Using Ruby on Rails” tutorial
by redha in Programming Languages

I'am working on "How to Create a Blog from Scratch Using Ruby on Rails" from http://sixrevisions.com. The tutorial was created for Rails 2.x. I try to get It working on Rails 3.x. . When I run server I and run localhost:3000 get some serious routing error:


Called from: C:/Ruby193/lib/ruby/gems/1.9.1/gems/actionpack-3.2.6/lib/ac
tion_dispatch/middleware/session/abstr

Are there 3 forms to invoke production, staging, etc in Ruby on Rails for rails server, rails console, and rake?
by apaunchev in Programming Languages

The forms I know of are:


For Rails 3.0:


for rails server:


rails server -e production

for rails console


rails console production

for rake


rake db:migrate RAILS_ENV=production

Is that it? I know for rails runner and rails dbconsole, it is


script/console won't work; reports “Missing the Rails gem. Please `gem install -v= rails`…” even though rails shows as installe
by l1feh4ck3r in Programming Languages

I'm trying to learn RoR, and running script/console fails, returning:


Loading development environment (Rails 2.3.5)
Missing the Rails gem. Please gem install -v= rails, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.


Both


'rails' command creates directory with /vendor/rails which uses wrong version of rails
by kalfa in Programming Languages

For some reason when I run rails command, it installs 2.2.3 version of Rails in /vendor/rails and webbrick uses that version instead of 2.3.5 which is installed as a gem.


If I delete that, then it uses the right directory. I remember using git submodule once, but I don't think that has anything to do with this.


How can I correct this? Thanks


Edit:



Heroku Rails 3 Rails.cache.class reports ActiveSupport::Cache::FileStore after I call Rails.application.config.cache_store = :redis_store, “#{ur
by krismolendyke in Network & Servers

Where url=redis://redistogo:XXXYYYZZZ@cod.redistogo.com:9362/


This is called in my initializer code.


Here is the other pertinent config options:


1) in production.rb


config.action_controller.perform_caching = true in my production.rb

2) In my controller:


caches_action :show, :layout => false,

Rails gem error while trying to upgrade rails project to rails 3
by wraith in Programming Languages

While trying to upgrade rails project from rails 2.3.5 to rails 3.0.3 i get following error:-


/opt/ruby-enterprise-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems.rb:230:in
activate': can't activate rails (=
2.3.5, runtime) for [], already activated rails-3.0.3 for []
(Gem::LoadError) from
/opt/ruby-enterprise-1.8.7-2010.01/lib/ruby/site_ruby/1.8/r


How to update my rails 3.0.0 beta 4 app to rails 3.0.0 RC and eventually to Rails 3?
by Davidpaul007 in Programming Languages

My first problem is a bundler conflict


$ bundle install
Fetching source index from http://rubygems.org/
No compatible versions could be found for required dependencies:
Conflict on: "bundler":
* bundler (0.9.26) activated by bundler (= 0.9.26, runtime)
* bundler (>= 1.0.0.rc.1, runtime) required in Gemfile
All possible versions of

For Rails, if there is a project that uses Rails 3.0.0, it looks for bundler 1.0.0 and it is there but rails server won't run?
by Wesley D. Radcliffe in Programming Languages

I have a Rails 3.0.0 project that was using Ruby 1.9.2. Now that I tried to run it on a new computer with the current rvm, it will say:


$ rails s
/Users/michael/.rvm/gems/ruby-1.9.2-p318@global/gems/bundler-1.1.3/lib/bundler/resolver.rb:129:in `block in resolve': Bundler could not find compatible versions for gem "bundler": (Bundler::VersionConflict)
In Gemfile:

How do I figure out why errors are occurring when running unit tests on app that is being upgraded from Rails 2.3 to Rails 3.0?
by Hosein Mohtasham in Programming Languages

I've been tasked with upgrading an app from Rails 2.3.5 to 3.0.19. This also involves upgrading Ruby from 1.8.6 to 1.8.7. After this upgrade is complete and stable, the plan is then to move to Ruby 1.9 and Rails 3.2.


Gems (output from bundle install), fyi:


Using rake (10.0.3)
Using abstract (1.0.0)
Using activesupport (3.0.19)
Using build

Rails console won't load, “Could not find gem 'rails (= 3.0.0.beta3) ruby”
by Davidpaul007 in Programming Languages

I typed in Rails console to begin working and received the error below:


MacBook-Pro:blog agreiner$ rails console
/Users/agreiner/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.1.3/lib/bundler/resolver.rb:287:in `resolve': Could not find gem 'rails (= 3.0.0.beta3) ruby' in the gems available on this machine. (Bundler::GemNotFound)
from /Users/agreiner/.rvm/gems/ruby-1.9.3-p194

Next
Privacy Policy - Copyrights Notice - Feedback - Report Violation - RSS 2014 © bighow.org All Rights Reserved .